Let us kick start your development by creating a custom project for you with all the right details in all the right places.

Get Ready For The Future Starting with v9 Rock requires Visual Studio 2017 and the .NET Framework 4.5.2 . If you're on 2015 you may want to upgrade soon. In the meantime, v8 and below still happily works with 2015.
Create My Project

Updating your SDK

Steps to keep your SDK up-to-date with upcoming Rock releases:

  1. Subscribe to our developer group below to get notified when a release goes beta.
  2. Set your "Update Server URL" Global Attribute to the beta repo: http://update.rockrms.com/F/rockbeta/api/v2/
  3. Use the "Update Rock" feature to update to the beta version.
  4. Commit the changes to your source control.