Photo of Tim Peterson


"Unable to authorize with the server" Error with Magnus Plugin

Looking for help troubleshooting an issue I am having with the Magnus plugin in VS Code. When expanding a server I simply get a generic error: Unable to authorize with the server.

I have worked through all the basic troubleshooting:

  • The IP is whitelisted in the Magnus settings (and shows as matching)
  • I am using a database username/password that is a member of the correct security group configured in Magnus
  • We have tried on multiple computers and multiple admin accounts

The Magnus plugin was working fine until recently. I know we have had a couple upgrades since it stopped working, but I'm not certain on the exact timeline, so I don't know if that could be a cause.

One final wrinkle... We have another Rock instance running on a separate sever for another non-profit. I can connect to that server just fine.

We are hosted in Azure and I'm wondering if there could be something blocking the traffic. But I'm not sure where to check for a more precise error code. Any ideas would be helpful.

  • Photo of Kevin Rutledge


    Two Questions:

    1. Have you updated the plugin recently?  or Have you started a new Workspace in VS Code?

    If so, I have found that you need to delete the Magnus server listed and go through the add process again where you will be given the opportunity to log in again. Changing workspaces sounds like it shouldn't matter but I ran into this issue.
    2. Has your IP Address changed?

    If so, you will need to add your new ip address in the settings under installed plugins.

  • Photo of Tim Peterson


    Hi Kevin,

    When it first stopped working I did go through and update the plugin on Rock and the plugin in VS Code. I also made sure VS Code was up to date.

    I have not started a new Workspace, but I have added and removed the server config in the plugin multiple times when troubleshooting and re-added it.

    As far as the IP goes, I have tried from multiple locations (Church office, church campus, home office). Each time I have added the correct external IP to the plugin settings and confirmed it shows that is it matching my current IP. Still no luck. 

    I am able to connect to our other Rock server, just not the main server that I've always used it with.

  • Photo of Jeff Richmond


    I have had this happen when I had a duplicate record for myself. After the duplicates were merged, the Confirmed checkbox on my user account was unchecked. I just had to edit the user account and recheck the Confirmed box. As soon as I did that, I was able to log into Magnus right away.