Photo of Marcus Carpenter


Error When Printing From Windows Client - An Invalid Request was Received from the Client

I have a ZD410 label printer.  I am able to successfully print our custom labels while the printer is networked and printing from the main kiosk.  However there are occasions where I need to take the printer to a remote location and connect the printer directly to a Windows 10 laptop via USB cable.  I have installed the Check-In Client v1.13.0.26 on the and the latest drivers for the ZD410 on the laptop.  I am able to print a test page from my laptop to the printer.  However, when I attempt to print a label from the Check-in client I receive the following error, "An invalid request was received from the client".  I have attached screenshots of my kiosk config and the error message.  I would greatly appreciate any insight into this issue.





  • Photo of Ben Murphy


    Hi Marcus! Are you running the latest Windows Check-in Client App? What version of Rock are you on? If you upgraded Rock and didn't update your Windows Check-in Client App I could potentially see issues. You'd have to update each Windows machine with the latest client app if it's out of date. There were updates to this client in the Rock v13.4+ range, I don't really remember when.

    Go to Admin Tools - Power Tools - External Applications to download the latest Windows Check-in Client to install on the machines. I can't say that this will fix your issue, but it's a good place to start.

    Finally, you can get near real-time support by asking questions directly to hundreds in the community chat by going to and asking in the #check-in channel. The Q&A is good, but a much slower way of receiving answers back and forth.

  • Photo of Marcus Carpenter


    Hey Ben,

    Thank you so much for responding so quickly.  I am currently running v14.4 of Rock, which I believe is the latest stable release and I have installed the latest version of the client from External Applications page.  Unfortunately it appears this did not resolve my issue as I am still receiving this error message.  I should also note that I have tried to perform this task on different Windows 10 computers resulting in the same error.  Thanks for your advice and I will reach out to the community at

    God Bless,